Fixning Följande paket har hållits tillbaka Fel vid uppdatering av Ubuntu och Debian-baserade Linux-distributioner

Ser du 'Följande paket har hållits tillbaka' Fel vid uppdatering av ditt system? Så här hanterar du detta fel i Ubuntu och andra Linux -distributioner.



Häromdagen var jag uppdaterar mitt Ubuntu -system . Jag föredrar kommandorads sättet att uppdatera systemet med hjälp av kombinationen av lämplig uppdatering och lämplig uppgradering .

Jag stötte på ett konstigt uppdateringsfel i Ubuntu den här gången. Det visade mig att det finns paket som kan uppgraderas men det kunde inte uppgradera dessa paket på grund av ett fel som läste:





Följande paket har hållits tillbaka :

Här är skärmdumpen av felet jag stötte på:



Förklaras: Orsak till följande paket har sparats fel och hur det åtgärdades

Ovanstående förslag på lösning bör lösa problemet för dig. Men är du nyfiken på vad som orsakade felet och hur åtgärdades det? Låt mig förklara det för dig.

Normalt, när du kör kommandona sudo apt update och sudo apt upgrade, uppdaterar det alla installerade paket till deras tillgängliga nyare versioner.

systemkrav för linux mint

Men om beroenden för ett installerat paket har ändrats så att det kräver installation av nya paket, kommer det installerade paketet inte att uppgraderas med systemuppdateringen och du ser ett paket som hålls tillbaka fel.

I exemplet här, när fwupd ursprungligen installerades, installerades inte tpm2-tools och tpm2-abrmd och fwupd berodde inte på det. Senare krävde en nyare version av fwupd installationen av dessa nya paket.

Detta är en mekanism i Debians Pakethanterare för APT som informerar dig om att ett redan installerat paket nu måste installera fler nya paket som beroende. När du manuellt och individuellt uppdaterar dessa paket ser du vilka nya paket som ska installeras och felet visas inte längre.

Du kan också använda apt full-upgrade/apt-get dist-upgrade istället för apt installera paketnamn i det här fallet men jag skulle inte rekommendera det. Den lämpliga fullständiga uppgraderingen kan automatiskt ta bort paket som det anser onödiga vid hantering av beroenden. Detta kan leda till oönskade situationer.

Har du åtgärdat det här felet?

Hjälpte den här lösningen dig att bli av med paketen som har hållits tillbaka fel? Om ja, välkomnar jag ditt snabba 'tack' -meddelande i kommentarsfältet. Om inte, meddela mig så ska jag försöka hjälpa dig vidare.


Gillar du det du läser? Dela det gärna med andra.

Intressanta Artiklar